Ir al contenido



Foto

Pasándose a FB 3

firebird

  • Por favor identifícate para responder
4 respuestas en este tema

#1 cram

cram

    Advanced Member

  • Miembro Platino
  • PipPipPip
  • 824 mensajes
  • LocationMisiones, Argentina

Escrito 05 mayo 2016 - 09:44

Hoy se me ocurrió instalar Firebird 3.0 en mi PC, don de previamente tenía instalado el Firebird 2.5.4 de 64 bits.

Lo interesante, más allá de una opción extra en la modalidad de ejecución es que ahora el instalador pide la contraseña y no hay que lidiar con CMD (en Windows) y GSEC.

Cuando intento usar registrar en EMS IB-FB Manager la base de datos creada con el Firebird anterior me encuentro con que no se puede, pues no hay compatibilidad con las versiones anteriores, es decir, que una base de datos creada con la versión 2, no puede ser abierta directamente con la versión 3 :| ... Eso por apurado y no leer bien el documento que viene con la instalación *-)

 

Cuando intento crear un alias (jamás conecto una db usando su ruta directamente) no encuentro el archivo alisases.conf. Bien está en databases.conf y tiene opciones extras. ;)

 

Para usar una base de datos hecha con la versión anterior, la 2, por ejemplo, es necesario (según dice el documento) crear un archivo de backup y luego rehabilitar con la versión 3. Aunque aun no pude hacerlo.

 

Supongo que será interesante hacer el traslado a la próxima versión, pues vero que ha cambiado bastante. Por ejemplo, el archivo de base de datos es mayor.

 

Saludos

 


  • 1

#2 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.260 mensajes
  • LocationArgentina

Escrito 05 mayo 2016 - 11:40

Yo no he migrado a la versión 3, pero estoy medio enterado de que los cambios son mayúsculos. Es otro mundo... sobre todo en lo que es seguridad. Hay cosas nuevas ahí ya que ahora la seguridad no es sólo hacia el motor, sino que hace a la base de datos (este es un pedido de ya vieja data). De este modo si alguien se hace de una DB hecha en FB3, no podrá abrirla con la simple SYSDBA/masterkey de la "vieja escuela" en un entorno limpio. ¡Deberá tener el usuario y contraseña con el permiso adecuado para esa base de datos! Lo que me parece algo totalmente lógico.

 

Que un utilitario como el que mencionas no pueda manejar la reciente versión no me extrañaría en lo más mínimo. Habrá que esperar. Es más, yo soy de la idea de que en lo posible no hay que meterse de una en una versión nueva... prefiero esperar a que salga alguna versión menor ante posibles errores y/o defectos que pudieran haberse pasado de largo.

Yo sugiero antes de embarcarse al hacer el cambiazo leer el Release Notes y por sobre todo leer el apartado Instalattion Notes, que seguro hay muchas cosas por considerar.

 

Saludos,


  • 0

#3 Rolphy Reyes

Rolphy Reyes

    Advanced Member

  • Moderadores
  • PipPipPip
  • 2.092 mensajes
  • LocationRepública Dominicana

Escrito 06 mayo 2016 - 07:30

Saludos.

 

@cram para el cambio de versión del motor siempre ha sido recomendado hacer un backup primero con la versión actual instalada en el equipo, luego proceder a realizar la instalación de la nueva versión y recuperar el backup.

 

Ellos agregaron más seguridad y añadieron más parámetros para el nuevo soporte SMP y multiple-core. 

 

Yo en estos momentos estoy embarcado estudiando el PostgreSQL porque la empresa ha optado por este gestor en vez de SQL Server, en casa tengo la versión de FB 2.5.4 aún no migro.

 

Debo admitir que PostgreSQL tiene muchas y bastantes características que les falta a nuestro querido FB, aunque PostgreSQL le faltan algunas que ya FB tiene incorporado.

 

Me gustaría ver a FB con tantas o más características como las tiene PostgreSQL pero le falta mucho camino por recorrer.


  • 2

#4 cram

cram

    Advanced Member

  • Miembro Platino
  • PipPipPip
  • 824 mensajes
  • LocationMisiones, Argentina

Escrito 06 mayo 2016 - 04:06

Así es Rolphy, yo también uso actualmente la versión 2.5.4 y como dijo Delphius, conviene esperar un poco.

Firebird tiene bugs conocidos, etc. Pero es tan liviano y simple que no lo cambiaría por ahora.

 

Saludos.


  • 0

#5 sir.dev.a.lot

sir.dev.a.lot

    Advanced Member

  • Miembros
  • PipPipPip
  • 545 mensajes
  • Location127.0.0.1

Escrito 19 julio 2016 - 05:34

Apurense que ya tenemos en cualquier momento FB4. :|  ;)  *-)   (y) (y) (y)

 

Mientras las manzanas caen.... vayan estresando al nuevo FB3.

 

Saludos.


  • 2





Etiquetado también con una o más de estas palabras: firebird