Ir al contenido


Foto

Invalid parameter al pasar de win7 a win10

invalid parameter win10 midas

  • Por favor identifícate para responder
3 respuestas en este tema

#1 cram

cram

    Advanced Member

  • Miembro Platino
  • PipPipPip
  • 829 mensajes
  • LocationMisiones, Argentina

Escrito 11 octubre 2021 - 08:57

Buen día a todos.

Estoy de vuelta en esto de la programación y quiero saludarle a todos lo que conforman este foro antes que nada.

 

Les comento:

Al pasar una aplicación escrita en Delphi 10.4 y Firebird 2.5.4.26856 (exactamente) en Windows 7 a una PC con windows 10 el primer error que tuve fue que no se encontraba la biblioteca de enlace dinámico Midas.dll es un error común, y se soluciona copiando este archivo en la carpeta donde se encuentra el ejecutable.

Pero luego, al ejecutar la aplicación (claro, al reconocer y abrir la base de datos) cuando intento hacer una modificación o inserción de una fila, aparece el error: "Invalid Parameter" sin más explicación y la transacción no se completa.

¿le pasó esto a alguien más?

No se si se trata de la biblioteca midas (que puede ser incorrecta) o alguna cuestión diferente.

¿alguien me da luz?

 

Desde ya muchas gracias.

 


  • 0

#2 egostar

egostar

    missing my father, I love my mother.

  • Administrador
  • 14.283 mensajes
  • LocationMéxico

Escrito 11 octubre 2021 - 06:22

Buen día a todos.

Estoy de vuelta en esto de la programación y quiero saludarle a todos lo que conforman este foro antes que nada.

 

Les comento:

Al pasar una aplicación escrita en Delphi 10.4 y Firebird 2.5.4.26856 (exactamente) en Windows 7 a una PC con windows 10 el primer error que tuve fue que no se encontraba la biblioteca de enlace dinámico Midas.dll es un error común, y se soluciona copiando este archivo en la carpeta donde se encuentra el ejecutable.

Pero luego, al ejecutar la aplicación (claro, al reconocer y abrir la base de datos) cuando intento hacer una modificación o inserción de una fila, aparece el error: "Invalid Parameter" sin más explicación y la transacción no se completa.

¿le pasó esto a alguien más?

No se si se trata de la biblioteca midas (que puede ser incorrecta) o alguna cuestión diferente.

¿alguien me da luz?

 

Desde ya muchas gracias.

 

Un gusto amigo cram

 

En lugar de colocar la DLL de midas, agrega en el uses de tu Form principal midaslib que encapsula la biblioteca dentro de tu aplicación.

 

A partir de ahí podremos ver que pasa.

 

Saludos


  • 0

#3 cram

cram

    Advanced Member

  • Miembro Platino
  • PipPipPip
  • 829 mensajes
  • LocationMisiones, Argentina

Escrito 12 octubre 2021 - 04:29

Muchas gracias Egostar.

Debería hacerlo en cada uno de los módulos.

Lo inquietante es que solo sucede al pasarlo a Windows 10

Creo que el archivo MIDAS.DLL que paso con el ejecutable es incorrecto.

Así que supongo que haciendo lo que dices. estará bien

 

Saludos


  • 0

#4 cram

cram

    Advanced Member

  • Miembro Platino
  • PipPipPip
  • 829 mensajes
  • LocationMisiones, Argentina

Escrito 12 octubre 2021 - 06:14

Bien, por mi parte está solucionado.

Agradezco la ayuda de Egostar una vez más y comento que pasó

 

Como el archivo midas.dll no se distribuye con la aplicación de forma automática y es necesaria cada vez que incluimos ClientDatasets, cosa que hice en casi todos los módulos, (les cuento en otro hilo por si a alguien le interesa).

No se me ocurrió mas tonta idea de copiar una versión antigua del mismo al directorio de la distribución de mi aplicación. Entonces, error asegurado y verbosidad jamás cuando se la necesita.

Busqué la versión de MIDAS.DLL en embarcader\studio\[versión]\redist\win32 (o win64 según el caso) la copié y asunto arreglado.

Por un momento creí que la base de datos se había corrompido.

Es decir que este problema no está en el lugar correcto, pues no es problema de Firebird como pensé

 

Saludos a la comunidad


  • 0





Etiquetado también con una o más de estas palabras: invalid parameter, win10, midas