Ir al contenido



Foto

Como configurar el httpd.conf de apache para que otras PC tengan acceso.


  • Por favor identifícate para responder
5 respuestas en este tema

#1 Electroadicto

Electroadicto

    Member

  • Miembros
  • PipPip
  • 13 mensajes
  • LocationLa Habana

Escrito 24 febrero 2017 - 10:34

Hola todos, Migre de la versión 2.4.4 de apache a la versión 2.4.23 y cambio todo por completo. Ahora las directivas son diferentes. De momento tengo entendido que se aplican en <Directory> --/-</Directoy>  Pero he intentado de todo y no doy pie con bola con eso al final me sigue diciendo FORBIDDEN , acceso denegado. He probado algunas cosas como requiered all granted y AllowOverride entre otras cosas pero nada de nada espero me puedan ayudar.


  • 0

#2 enecumene

enecumene

    Webmaster

  • Administrador
  • 7.212 mensajes
  • LocationRepública Dominicana

Escrito 25 febrero 2017 - 07:18

Saludos, ¿cual es el acceso desde otras PC?, ¿a la base de datos?.


  • 0

#3 Electroadicto

Electroadicto

    Member

  • Miembros
  • PipPip
  • 13 mensajes
  • LocationLa Habana

Escrito 25 febrero 2017 - 03:52

No a la base de datos, si no a los sitos que tengo en la carpeta www. Por ej tengo montado un forum y no se puede tener acceso al forumdesde otras pc de ninguna manera, si puedo entrar desde la misma pc en la que esta instalado el wamp server. pero si hago esto 192.168.23.2:8080 desde otra pc  no puedo entrar dice que FORBIDDEN, La cosa es que acabo de instalar el WAMP server pero no se conf el httpd.conf para dar el acceso. Me copias???


  • 0

#4 enecumene

enecumene

    Webmaster

  • Administrador
  • 7.212 mensajes
  • LocationRepública Dominicana

Escrito 25 febrero 2017 - 05:02

Prueba colocando el puerto 8080 en el firewall de windows, para que otros puedan acceder a traves de ese puerto.

 

Saludos.


  • 0

#5 Electroadicto

Electroadicto

    Member

  • Miembros
  • PipPip
  • 13 mensajes
  • LocationLa Habana

Escrito 25 febrero 2017 - 06:50

No es problema del puerto. El puerto yo se lo puse a propósito. Una vez que ella me die FORBIDDEN es una señal de que se comunica con el servidor sin ningún problema usando el puerto 8080. El problema es que es un servidor acabado de instalar y las directivas del <Directori> / </Directory> Por default viene todo configurado para impedir el acceso. Por ejemplo en la versión anterior para yo permitir la entrada era así.

 

Apache version 2.4.4 PHP 5.4.12 Mysql 5.6.12


php
  1. <Directory "c:/wamp/www">
  2. #
  3. # Possible values for the Options directive are "None", "All",
  4. # or any combination of:
  5. # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
  6. #
  7. # Note that "MultiViews" must be named *explicitly* --- "Options All"
  8. # doesn't give it to you.
  9. #
  10. # The Options directive is both complicated and important. Please see
  11. # http://httpd.apache.org/docs/2.4/mod/core.html#options
  12. # for more information.
  13. #
  14. Options Indexes FollowSymLinks
  15.  
  16. #
  17. # AllowOverride controls what directives may be placed in .htaccess files.
  18. # It can be "All", "None", or any combination of the keywords:
  19. # AllowOverride FileInfo AuthConfig Limit
  20. #
  21. AllowOverride All
  22.  
  23. #
  24. # Controls who can get stuff from this server.
  25. #
  26. # Require all granted
  27. # onlineoffline tag - don't remove
  28. Order Deny,Allow
  29. Allow from all
  30. Allow from 127.0.0.1
  31. Allow from ::1
  32. Allow from localhost
  33. </Directory>

Y en el que acabo de instalar es así

 

 

 

 

Apache version 2.4.23  PHP 7.0.10  Mysql 5.7.14


php
  1. <Directory "${INSTALL_DIR}/www/">
  2. #
  3. # Possible values for the Options directive are "None", "All",
  4. # or any combination of:
  5. # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
  6. #
  7. # Note that "MultiViews" must be named *explicitly* --- "Options All"
  8. # doesn't give it to you.
  9. #
  10. # The Options directive is both complicated and important. Please see
  11. # http://httpd.apache.org/docs/2.4/mod/core.html#options
  12. # for more information.
  13. #
  14. Options +Indexes +FollowSymLinks +Multiviews
  15.  
  16. #
  17. # AllowOverride controls what directives may be placed in .htaccess files.
  18. # It can be "All", "None", or any combination of the keywords:
  19. # AllowOverride FileInfo AuthConfig Limit
  20. #
  21. Options Indexes FollowSymLinks
  22. AllowOverride all
  23. Require all Granted
  24.  
  25. #
  26. # Controls who can get stuff from this server.
  27. #
  28.  
  29. # onlineoffline tag - don't remove
  30.  
  31.  
  32.  
  33.  
  34. </Directory>


  • 0

#6 Electroadicto

Electroadicto

    Member

  • Miembros
  • PipPip
  • 13 mensajes
  • LocationLa Habana

Escrito 26 febrero 2017 - 01:45

Ya encontre la solucion aqui se los dejo para el que la necesite.

 

Aplican la conf de arriba y despues van a virtual hosts y aplican esto


php
  1. # Virtual Hosts
  2. #
  3. # El puerto 8080 es opcional por lo genera es *:80
  4. <VirtualHost *:8080>
  5. ServerName localhost
  6. DocumentRoot c:/wamp64/www/
  7. <Directory "c:/wamp64/www/">
  8. Options Indexes FollowSymLinks MultiViews
  9. AllowOverride None
  10. Order allow,deny
  11. allow from all
  12.  
  13. </Directory>
  14. </VirtualHost>
  15. #


  • 1