Ir al contenido



Foto

Mi aplicacion me esta bloqueando la red ?


  • Por favor identifícate para responder
4 respuestas en este tema

#1 JoAnCa

JoAnCa

    Advanced Member

  • Miembro Platino
  • PipPipPip
  • 731 mensajes
  • LocationPinar del Río, Cuba

Escrito 10 septiembre 2019 - 10:09

Desde hace un tiempo he notado que se me bloquea el acceso a todo lo que tenga que ver con la red, incluso al localhost.
Si la conexion ya esta establecida se mantiene, pero no puedo hacer nuevas conexiones(en los casos de mysql y VNC, pero no en el navegador web).

Esto lo hace de forma variable, a veces no lo hace en dias, otras veces varias veces en el dia.

En conclusiones, me di cuenta que todo esto lo hace cuando estoy usando una aplicacion hecha en Delphi XE7 y con acceso a mysql que está en servidor.
En la aplicacion uso los componentes MITEC MSIC para detectar datos del hardware, pero la deteccion de hardware solo se hace si se selecciona esa opcion, si no, solo es consultar y escribir en registros.

Ahora estoy usando Windows 10, pero recuerdo que cuando tenia windows 7, no se me bloqueaba la red, pero si el servidor de mysql, pues cuando intentaba acceder me decia algo de que se habia bloqueado mi acceso por multiples solicitudes de conexion o algo asi. Entonces tenia que entrar al servidor y usar "flush hosts"


Que me podrá estar causando el problema?
  • 0

#2 JoAnCa

JoAnCa

    Advanced Member

  • Miembro Platino
  • PipPipPip
  • 731 mensajes
  • LocationPinar del Río, Cuba

Escrito 13 septiembre 2019 - 11:36

Quizas lo que necesite sea algo que me informe de todas las actividades que hace mi aplicacion en segundo plano, que puertos o protocolos usa, cuantas peticiones envia a MySQL, etc.

Editado por JoAnCa, 13 septiembre 2019 - 11:36 .

  • 0

#3 JoAnCa

JoAnCa

    Advanced Member

  • Miembro Platino
  • PipPipPip
  • 731 mensajes
  • LocationPinar del Río, Cuba

Escrito 05 noviembre 2019 - 03:43

Despues de reinstalar windows(por otro problema), para ir descartando el conflicto que me afecta, llegue a la conclusion de que cuando instale el antivirus nod32 v8, se me presento el problema de nuevo.

Sin en el antivirus todo funciona ok cuando abro mi aplicacion, cuando instalo el antivirus al rato de estar funcionando mi aplicacion, se bloquean todas las conexiones de red y tambien el acceso al administrador de tareas y a configuracion de windows

Lo exttaño del caso es que en otra PC de la misma red y con el mismo antivirus, no pasa nada, funciona todo ok

Que podra tener mi aplicacion que entra en conficto con el NOD32v8 ??

Editado por JoAnCa, 05 noviembre 2019 - 03:48 .

  • 0

#4 egostar

egostar

    missing my father, I love my mother.

  • Administrador
  • 13.988 mensajes
  • LocationMéxico

Escrito 06 noviembre 2019 - 09:46

Hola amigo,

 

Es probable que en la otra maquina en algún momento se haya indicado que no valide la aplicación y por eso ya está en la lista de excepciones. No se, algo por el estilo.

 

Saludos


  • 0

#5 enecumene

enecumene

    Webmaster

  • Administrador
  • 7.408 mensajes
  • LocationRepública Dominicana

Escrito 09 noviembre 2019 - 09:16

Revisa las excepciones y/o los puertos bloqueados en el Antivirus..


  • 0