Ir al contenido


Foto

Problemas en configurar REST Debugger para consumir un servicio

Debugger servicio

  • Por favor identifícate para responder
2 respuestas en este tema

#1 tiquinho

tiquinho

    Member

  • Miembros
  • PipPip
  • 20 mensajes

Escrito 17 septiembre 2020 - 05:48

Hola buenas noches a todos

 

Mi caso es 

 

Tengo la siguiente url: https://facelectroni...e3-3df769ceab98

 

El token es: c6ba33e743a13add38b0f71d8ad4739f9bba5d937bec328befc4a74b3ed7c05a

 

No se necesita ni usuario ni contraseña

 

El Json: 

 

{"sendmail":"true","number":"1233109","type_document_id":"1","date":"2020-09-16T15:27:56-05:00","time":"15:27:56","customer":{"identification_number":"901021565","dv":"1","type_document_identification_id":"31","type_organization_id":"1","municipality_id":"743","type_regime_id":"49","name":"EMSSANAR S.A.S.","phone":"(0927) 234080 - 294681 - 234080","address":"CARRERA 30A NO. 13 - 63 BARRIO SAN ignacio","email":"wilmer.camacho@sitis.com.co","merchant_registration":"123","prepaid_payment":{"idpayment":"1130677","paidamount":"3400.000000000000","receiveddate":"2020-09-16T15:27:56-05:00","paiddate":"2020-09-16T15:27:56-05:00","instructionid":"COPAGO"}},"allowance_charges":[{"charge_indicator":"true","discount_id":"","allowance_charge_reason":"","amount":"30300","base_amount":""}],"tax_totals":[{"tax_id":"ZY","percent":"0","tax_amount":"0.00","taxable_amount":"0.00"}],"legal_monetary_totals":{"line_extension_amount":"30300","tax_exclusive_amount":"0.0","tax_inclusive_amount":"30300","allowance_total_amount":"0","charge_total_amount":"0.0","payable_amount":"26900"},"invoice_lines":[{"unit_measure_id":"890201","invoiced_quantity":"30300","line_extension_amount":"30300","free_of_charge_indicator":"false","tax_totals":[{"tax_id":"17","tax_amount":"0.00","taxable_amount":"0.00","percent":"0"}],"description":"CONSULTA DE PRIMERA VEZ POR MEDICINA GENERAL","code":"890201","type_item_identification_id":"","price_amount":"","base_quantity":1}]}

 

 

Realizo la configuración en el postman y se conecta bien

 

post-19646-0-43565700-1600386159_thumb.j

 

post-19646-0-28835700-1600386173_thumb.j

 

post-19646-0-86519600-1600386182_thumb.j

 

 

Pero cuando lo valido en REST Debugger me sale error, no se que me falta configurar, o bueno no se como agregar el json porque va sin name

 

 

post-19646-0-29042500-1600386193_thumb.j

 

post-19646-0-10796100-1600386202_thumb.j

 

La verdad no se como configurar el Json para que me funcione.

 

No se cual sea el equivalente del Body/raw en el debugger


  • 0

#2 egostar

egostar

    missing my father, I love my mother.

  • Administrador
  • 14.141 mensajes
  • LocationMéxico

Escrito 18 septiembre 2020 - 08:40

Hola tiquinho

 

En efecto, hay algo que no está realizando correctamente RESTDebugger, investigaré más a fondo que es lo que pasa y rsolver el "misterio".

 

Saludos


  • 0

#3 tiquinho

tiquinho

    Member

  • Miembros
  • PipPip
  • 20 mensajes

Escrito 18 septiembre 2020 - 08:18

Hola tiquinho

 

En efecto, hay algo que no está realizando correctamente RESTDebugger, investigaré más a fondo que es lo que pasa y rsolver el "misterio".

 

Saludos

 

Gracias egostar, te lo agradecería mucho


  • 0





Etiquetado también con una o más de estas palabras: Debugger, servicio