Ir al contenido



Foto

Acentos - Cambiar distribucion teclado en Lubuntu


  • Por favor identifícate para responder
24 respuestas en este tema

#1 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 28 abril 2012 - 02:58

Hola chicos,
Aqui vengo con mi primera pregunta en Linux, mas en concreto sobre para la distribucion Lubuntu.
Resulta ser que el "nuevo equipo" con el que cuento, ya tenia instalado esta version y no podia darme el lujo de ir formateando y estar poniendo otra distro... como Ubuntu, sin L. Porque tambien tenia que estar poniendo Windows, etc. porque me iba a estar demorando mas en empezar.
Y bueno, tengo un problemita con el teclado, el mio es español y funciona bien en todas las teclas excepto si no fuera por los acentos. Simplemente no me los coloca. Observen: ´a a´ `a 'a

En Preferencias -> Teclado y raton busco a ver si es cosa de distribucion del teclado pero no veo modo alguno de configurarlo. Leo que esta puesto lxkeymap pero no me permite cambiarlo. ¿Como puedo proceder para cambiarlo?

Saludos,
  • 0

#2 enecumene

enecumene

    Webmaster

  • Administrador
  • 7.409 mensajes
  • LocationRepública Dominicana

Escrito 28 abril 2012 - 03:12

Revisa en Configuracion del sistema -> hardware -> Teclado -> Distribuciones y dinos que distribicion tienes.

Saludos.
  • 0

#3 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 28 abril 2012 - 03:30

No veo algo parecido a eso Amigo. Parece que es diferente en Lubuntu
Aviso ademas por las dudas que estoy con el entorno GNOME.

Tengo Herramientas del Sistema -> System Profiler and Brenchmark. Desde alli puedo ver en Input Device (no se porque en ingles si esta instalado el idioma español  ^o| ) que tengo:
AT Transalated Set 2 keyboard

En Preferencias -> teclado y raton lo unico que se puede configurar es la velocidad de retardo e intervalo de repeticion. Se indica la distribucion lxkeymap pero pulsando en la misma no se hace nada.

Saludos,

  • 0

#4 enecumene

enecumene

    Webmaster

  • Administrador
  • 7.409 mensajes
  • LocationRepública Dominicana

Escrito 28 abril 2012 - 03:38

Que raro Ubuntu tambien es con entorno GNOME, como LUBUNTU usa LXDE probemos lo siguiente, abre un terminal y escribe lo siguiente:



delphi
  1. sudo setxkbmap -rules xfree86 -model pc105 -layout "es, es"  -option "grp:alt_shift_toggle"



Saludos.
  • 0

#5 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 28 abril 2012 - 03:46

Con dicho comando si funcionó.  :)

Va a ser un dolor de parto este Lubuntu. Tengo ganas de matar a mi hermano, porque carajos directamente no trabajó con Ubuntu que es más "completo"

Saludos,
  • 0

#6 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 28 abril 2012 - 04:06

Fernando, ahora resulta que no puedo utilizar las teclas de cursor, ni insert, supr, o cualquiera de esas bien; por ejemplo Fin abre el menú de inicio. Y el alt gr se comporta como enter. Tampoco responde el / y el enter del teclado numérico.  :  8o|

Saludos,



  • 0

#7 enecumene

enecumene

    Webmaster

  • Administrador
  • 7.409 mensajes
  • LocationRepública Dominicana

Escrito 28 abril 2012 - 05:21

Te dejare el manual de configuracion del teclado, lo dificil es determinar tipo de teclado y su variante.

http://www.xfree86.o...XKB-Config.html

Saludos.
  • 0

#8 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 28 abril 2012 - 05:34

Ha  :(
Al menos se que es el Everbra (chino) modelo KB 2041 pero no creo que ayude demasiado ¿o si?

Saludos,
  • 0

#9 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 28 abril 2012 - 06:31

Vaya... ha bastado un reinicio para volver a como estaba antes. Al menos ahora ya puedo utilizar los cursores y el resto de las teclas bien.

Saludos,
  • 0

#10 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 29 abril 2012 - 01:27

Anoche mientras rebuscaba en la red encontré un sitio que sugería que se utilizara este comando:



delphi
  1. sudo setxkbmap -layout 'es, es' -model pc105



Y funciona perfectamente todo como debe pero solo mientras dura la sesión activa. En el momento en que uno reinicie o prenda nuevamente el equipo vuelve al estado anterior... sin funcionar el tema de los acentos.

Ya me he asegurado de que exista en Preferencias -> Idiomas de que esté disponible en 1er lugar de la lista el Español y esta instalado con dicho idioma.

En el mismo sitio se dice que para hacer efectivo dicho cambio se debe modificar el archivo xorg.conf que está en /etc/X11 con esto:



delphi
  1. Section "InputDevice"
  2. Identifier "Generic Keyboard"
  3. Driver "kbd"
  4. Option "CoreKeyboard"
  5. Option "XkbRules" "xorg"
  6. Option "XkbModel" "pc105"
  7. Option "XkbLayout" "es"
  8. Opcion "XkbOptions" "lv3:ralt_switch"
  9. EndSection



Algunas personas dejaron comentarios diciendo que al alterar dicho archivo tuvieron problemas con sus tarjetas de videos y otros más.

Yo me arriesgué a modificar dicho archivo pero como bien se merece el punto a favor Linux, me indica que el archivo no se puede modificar por no tener permisos de escritura.

Aqui mi pregunta es, si es posible modificar dicho archivo ¿Entonces como he de proceder?
Algo que me ha llamado la atención, y admito que es una de las cosas que me marea Linux, es que la cuenta de usuario estaba puesta como del tipo personalizada (creo que era ese el nombre; en cuanto entre en Lubuntu corrijo esto), yo la dejé como del tipo administrador. Esto de los usuarios, grupos y los permisos es muy nuevo para mi.

Efectivamente Fernando, Lubuntu utiliza LXDE yo lo confundí con GNOME... ¡Tengo tantas cosas que aprender!

Yo ayer estaba confundido, producto de la desesperación, cansancio y que tenía mi mente en otra cosa, mi teclado es Español con distribución Hispanoamericana de 105 teclas. Ligeramente diferente de éste.
El mio dispone además de teclas para Power, Sleep, Wakeup; después de Ñ tengo una sola tecla: la de ´¨{ mientras que al lado de P tengo dos: `^[ y +*]. A la izquierda de backspace tengo una tecla más (la que normalmente encontrarían en la fila de ASD..Ñ): ç} y por tanto más a la izquierda es de encontrarse a: ¡¿ y '?
Se que esto es de menos, pero por las dudas les comento. Adjunto una imagen para que se entienda mejor, es un dibujo que tengo hecho para recordar bien el orden de las teclas para cuando lo limpio  :D . Porque el orden de las teclas "especiales" es diferente a otros que he tocado y me marea.

Si alguien más puede echarme luz se los agradecería.

Saludos,

Archivos adjuntos


  • 0

#11 enecumene

enecumene

    Webmaster

  • Administrador
  • 7.409 mensajes
  • LocationRepública Dominicana

Escrito 29 abril 2012 - 01:37

Pues mi estimado para poder modificar ese archivo debes usar la terminal:



delphi
  1. sudo gedit /etc/X11/xorg.conf



Se te abrira el editor de texto con el contenido de xorg.conf como ROOT.

Saludos.
  • 0

#12 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 29 abril 2012 - 01:49

Pues mi estimado para poder modificar ese archivo debes usar la terminal:



delphi
  1. sudo gedit /etc/X11/xorg.conf



Se te abrira el editor de texto con el contenido de xorg.conf como ROOT.

Saludos.

Me lo imaginaba... que me tendría que enfrentar a esa parte engendra de Linux, y sus comandos... su ROOT y demás. Y luego dicen que Ubuntu y sus ramas son fáciles.... ¡Mamaaa! :D

Saludos,
  • 0

#13 enecumene

enecumene

    Webmaster

  • Administrador
  • 7.409 mensajes
  • LocationRepública Dominicana

Escrito 29 abril 2012 - 01:52

SI hubieras tenido un entorno GNOME no tuvieras que usar los comandos :).
  • 0

#14 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 29 abril 2012 - 02:10

SI hubieras tenido un entorno GNOME no tuvieras que usar los comandos :).

Grrrrrr..... Maldigo a Lubuntu y su LXDE. Más razones para putearle a mi hermano  :@
Si a esta máquina le debiera andar perfectamente Ubuntu, Ha... pero creo que ahora ya viene por defecto con Unity y no GNOME.

Más tarde voy a por el teclado en Lubuntu. Ahora no quiero enfermarse... mucho tuve ayer  :D Me va a ser mucha falta una biblia de Linux como medicina  :

Saludos,
  • 0

#15 enecumene

enecumene

    Webmaster

  • Administrador
  • 7.409 mensajes
  • LocationRepública Dominicana

Escrito 29 abril 2012 - 02:34

En realidad Unity y Gnome conviven juntos en Ubuntu :)
  • 0

#16 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 11 mayo 2012 - 11:21

Hola,
Resulta ser que no dispongo de de gedit, pero si nano.

El asunto es que cuando hago: sudo nano /etc/x11/xorg.conf me abre el archivo y no me muestra nada, como si no contuviera nada escrito. Pero en efecto si lo hay; puesto que si abro con el editor por defecto (leadpaf) con menu contextual -> abrir puedo leer lo que tiene.

¿Es un problema de nano o que? Porque efectivamente nano se ejecuta, y lo abre, pero la pantalla esta en negro... vacia. No se lee lo que ya tiene el archivo. ¿Se podria utilizar, o podria resultar conveniente, leadpaf para editar dicho archivo? No he probado con hacer sudo leadpaf /etc/x11/xorg.conf por temor.

¿O que opciones me recomiendan?

Saludos,

  • 0

#17 enecumene

enecumene

    Webmaster

  • Administrador
  • 7.409 mensajes
  • LocationRepública Dominicana

Escrito 11 mayo 2012 - 11:32

Puedes hacerlo sin temor, yo lo hago con cualquier editor de texto que tengo instalado, dele dele.

Saludos.
  • 0

#18 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 11 mayo 2012 - 11:51

Puedes hacerlo sin temor, yo lo hago con cualquier editor de texto que tengo instalado, dele dele.

Saludos.

OK. Enseguido mando el comando y reinicio.
Si algo no anda ya vendre de nuevo por aqui.

Ojala no me traiga sorpresas como a algunos de los que comentaron en la pagina que recomedaba la solucion.

Saludos,
  • 0

#19 Delphius

Delphius

    Advanced Member

  • Administrador
  • 6.280 mensajes
  • LocationArgentina

Escrito 11 mayo 2012 - 12:37

Ya me acorbarde de nuevo...
si hago sudo leafpad /etc/x11/xorg.conf me abre una nueva ventana del editor (fuera de LKTerminal) ya que este es visual, y totalmente en blanca  :o  :|
Estoy pensando que independientemente de editores que use, el haberle dado orden sudo hace que se genere un archivo en blanco y que tal vez deba reescribirlo entero, y por consiguiente copiar todo lo que tenia antes de editarlo.

¿Es normal esto, que se muestre en blanco?

Saludos,
  • 0

#20 enecumene

enecumene

    Webmaster

  • Administrador
  • 7.409 mensajes
  • LocationRepública Dominicana

Escrito 11 mayo 2012 - 01:46

Existe la remota posibilidad de que no estas apuntando al archivo correcto o que esa no es la ruta correcta, al hacer ese comando si no se encuentra el archivo lo que hace es que crea uno nuevo con ese nombre y esa ruta, comprueba bien la ruta exacta de xorg.conf (o si ese es el nombre correcto).

Saludos.
  • 0